ejb deployment in weblogic 9.2

Discussions

EJB programming & troubleshooting: ejb deployment in weblogic 9.2

  1. ejb deployment in weblogic 9.2 (2 messages)

    Hi I've deployed a stand alone ejb (helloWorld) in weblogic 9.2 as a jar file. The status of the deployment says active. bea docs says we need to start the deployment inorder to service the requests. When I tried to start the service in deployments using (From WebLogic Console) start button --> Servicing all requests it gives me following warnings "The library helloWorld has been excluded. Libraries are always managed as part of another application. All of the Deployments selected are currently in a state which is incompatible with this operation. No action will be performed." Not sure whether my ejb has been deployed or not. When I run the client its not able to identify jndi name. Can any one please help Thanks in advance. Regards, Sathwik

    Threaded Messages (2)

  2. ejb deployment in weblogic 9.2[ Go to top ]

    Hi, You can't start the library as it refers to an application. First you need to stop all the applications to which your library will be referring, then after stopping the applications try to deploy the library file. At last when you activate changes it will be in activate state automatically. There will be no need to start the library file. Then after you can start the applications.

  3. ejb deployment in weblogic 9.2[ Go to top ]

    Hi,

    You can't start the library.

    For this before deploying the library file ?you ?h?a?v?e to stop all the applications to which your library will be referring, then after stopping the applications try to deploy the library file. At last when you activate changes it will be in activate state automatically. There will be no need to start the library file. Then after you can start the applications.?