Discussions

Web tier: servlets, JSP, Web frameworks: Urgent help needed, please!

  1. Urgent help needed, please! (5 messages)

    Using servlet, I was successful in executing a dos batch file that copies files from a mapped drive to my machine. But this is using JBuilder4 in my machine. But when I deployed it with iPlanet as my web server, it cannot access the same mapped drive.

    "O" is the mapped drive
    the command prompt displays shows

    C:/server-root/https-server.instance/config> O:
    Access is denied.

    But when I do this manually, like opening a dos window and changing directory up to config folder, then changing drive to letter O, it works fine. By the way, I'm working on Windows NT4 system.

    Could this be a network problem, webserver...?

    Thank you,
    Noel
    popoy143@aol.com

    Threaded Messages (5)

  2. Urgent help needed, please![ Go to top ]

    Check to see what userid the webserver is running under on the NT box and see if it has permission to access the mapped drive. I think you'll find that it doesn't have the neccessary permissions so go ask your NT administrator to give that id access.

    Greg.
  3. Urgent help needed, please![ Go to top ]

    I've seen this before. The problem I came across was the fact that the server is running with a different user that doesn't have the drive as a default mapping.

  4. Urgent help needed, please![ Go to top ]

    Yeah that could be it too...
  5. Urgent help needed, please![ Go to top ]

    Well, Trever and Gregg, I do appreciate your help on this. But, Gregg, I've tried what you have suggested. But NT is probably checking the access of the web server which I believe is the "anonymous user" which Microsoft uses too in their IIS. But Trever, could you elaborate more on what you are suggesting. Thanks.
  6. Urgent help needed, please![ Go to top ]

    Unfortunately I don't have any experience with IIS but I had a similiar experience with Weblogic not being able to create any files in a directory local to the server on it's own harddrive! It turned out that the userid that the NT server logged onto the network with didn't have the necessary permissions to create or read files in that particular directory.

    What I did to resolve it was right click on the directory affected, select "Properties", "Security" tab, "Permissions" button and then added the userid, set the access rights and save the settings using the "Apply" button. The similiar procedure can be done for shared network drives however your NT administrator has to give the userid affected access to that shared resource. If it is the "anonymous user" it might need the access but I have a feeling it is actually the logon userid of the NT server itself that is the one that has to be set.

    A bit of warning though... Giving the anonymous user access to a shared resource can be somewhat of a security risk that you may not want to manage...

    Greg.