SQL Server DataSource problem


General J2EE: SQL Server DataSource problem

  1. SQL Server DataSource problem (1 messages)

    I am working on a project that is trying to implement a DAO pattern, we have a session bean which uses a dao ( which is a pojo), the dao then tries to get hold a datasource which is registered with the server, the error below is the message I am getting.

    Resource reference jdbc/bfl/ericDS could not be located, so default values of the following are used: [Resource-ref settings]res-auth: 1 (APPLICATION)
    res-isolation-level: 0 (TRANSACTION_NONE)
    res-sharing-scope: false (UNSHAREABLE)
    res-resolution-control: 999 (undefined)

    [23/09/04 11:13:36:377 BST] 7eae8628 DSConfigurati E DSRA0023E: The DataSource implementation class "com.microsoft.jdbcx.sqlserver.SQLServerDataSource" could not be found.
    [23/09/04 11:13:36:392 BST] 7eae8628 DSConfigurati E DSRA0011E: Exception: java.lang.ClassNotFoundException: com.microsoft.jdbcx.sqlserver.SQLServerDataSource

    Can anyone point me in the right direction
  2. SQL Server DataSource problem[ Go to top ]

    The above problem I am having is due to the fact that when I run Websphere the Dao cannot seem to access the JNDI reference. I know the datasource is registered as I can access the reference through the admin console, the help file seems to indicate that I need to use the JMX API, is there no other way?
    Any help would be greatly appreciated as I have spent a lot of time trying to solve this problem.
    I have run a test outside of websphere just to make sure I am using the SQL server JDBC driver correctly and this worked fine?