Unable to load performance pack getting UnsatisfiedLinkError


Performance and scalability: Unable to load performance pack getting UnsatisfiedLinkError

  1. hi,

    i am getting this error while i start weblogic6.0 but still the server is running but unable to load performance pack...
    can anybody tell how to go about this.....

    thanks in advance....

    <Sep 20, 2000 10:09:26 AM GMT+05:30> <Error> <Performance Pack> <Unable to load
    performance pack, using Java I/O.
    java.lang.UnsatisfiedLinkError: no muxer in java.library.path
            at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1312)
            at java.lang.Runtime.loadLibrary0(Runtime.java:749)
            at java.lang.System.loadLibrary(System.java:820)
            at weblogic.socket.PosixSocketMuxer.<init>(PosixSocketMuxer.java:90)
            at java.lang.Class.newInstance0(Native Method)
            at java.lang.Class.newInstance(Class.java:237)
            at weblogic.socket.SocketMuxer.makeTheMuxer(SocketMuxer.java:128)
            at weblogic.socket.SocketMuxer.getMuxer(SocketMuxer.java:83)
            at weblogic.t3.srvr.ListenThread.run(ListenThread.java:224)
  2. You should have $WEBLOGIC_HOME/lib/solaris directory in your LD_LIBRARY_PATH so that the server can load the performance pack (which is a shared library called libmuxer.so).

  3. I tried to install weblogic 6.1 on my PC. I downloaded the weblogic610sp7_win.exe from their site. Although the specification suggests for 128 MB ram(min) and win2000 or above, I went ahead with the installation ( my config is 64 mb ram and win98).
    Now when I run the startweblogic.cmd( I changed all .cmd to .bat as win98 does nt recognise .cmd) i get the following error message.
    <Nov 14, 2005 10:28:16 PM PST> <Notice> <WebLogicServer> <SSLListenThread listen
    ing on port 7002>
    <Nov 14, 2005 10:28:16 PM PST> <Error> <Performance Pack> <Unable to load perfor
    mance pack, using Java I/O instead.
    Please ensure that libmuxer library is in C:\BEA\JDK131\BIN;.;C:\WINDOWS\SYSTEM;
    java.lang.UnsatisfiedLinkError: no muxer in java.library.path
            at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1344)
            at java.lang.Runtime.loadLibrary0(Runtime.java:744)
            at java.lang.System.loadLibrary (System.java:815)
            at weblogic.socket.PosixSocketMuxer.<init>(PosixSocketMuxer.java:192)
            at java.lang.Class.newInstance0(Native Method)
            at java.lang.Class.newInstance(Class.java:232)
            at weblogic.socket.SocketMuxer.makeTheMuxer(SocketMuxer.java:193)
            at weblogic.socket.SocketMuxer.getMuxer(SocketMuxer.java:144)
            at weblogic.t3.srvr.ListenThread.run(ListenThread.java:233)
    <Nov 14, 2005 10:28:17 PM PST> <Notice> <Management> <Starting discovery of Mana
    ged Server... This feature is on by default, you may turn this off by passing -D
    weblogic.management.discover=false >
    <Nov 14, 2005 10:28:17 PM PST> <Notice> <WebLogicServer> <Started WebLogic Admin
     Server "myserver" for domain "mydomain" running in Production Mode>
    I tried "google" and got some suggestions like this...
    and I added it to my path..Now my autoexec looks like this


    SET PATH=%PATH%;C:\jdk131\bin;
    SET PATH=%PATH%;C:\j2ee13\bin
    SET PATH=%PATH%;C:\bea\wlserver6.1\BIN
    SET PATH=%PATH%;C:\bea\wlserver6.1\lib
    SET JAVA_HOME=C:\jdk131
    SET J2EE_HOME=C:\j2ee13
    SET LD_LIBRARY_PATH =C:\bea\wlserver6.1\\lib\solaris
    SET JPS_HOME=C:\C:\jps1.1.2
    SET wl_HOME=C:\bea\wlserver6.1

    set classpath=%classpath%;c:\jdk131\lib
    set classpath=%classpath%;c:\j2ee13\lib
    set classpath=%classpath%;C:\bea\wlserver6.1\LIB;C:\bea\wlserver6.1\lib\solaris
    set classpath=%classpath%;C:\bea\wlserver6.1\WEBLOGIC_HOME\lib\solaris

    still it is givin the same error, what shall I do?

    Pls offer any suggestions.