Must jdk1.3 be used to deploy EJB with WebLogic 7.0?

Discussions

EJB programming & troubleshooting: Must jdk1.3 be used to deploy EJB with WebLogic 7.0?

  1. Must jdk1.3 be used to deploy EJB with WebLogic 7.0? (4 messages)

    When I use JBuilder to deploy my EJB, errors will be encountered if I use jdk1.4.1, but if I use jdk1.3 instead of jdk1.4.1, deployment will succeed, can any one tell me why? Thanks!

    The error while using jdk1.4.1 is as follows:
    Unable to deploy EJB: UserMessagesEJB from LBSystem.jar:
    weblogic.ejb20.WLDeploymentException: Error while reading 'META-INF/weblogic-cmp-rdbms-jar.xml'. The error was:
     ZipFile closed.
    at weblogic.ejb20.persistence.PersistenceType.setTypeSpecificFile(PersistenceType.java:541)
    at weblogic.ejb20.persistence.PersistenceType.setupDeployer(PersistenceType.java:408)
    at weblogic.ejb20.deployer.CMPInfoImpl.setup(CMPInfoImpl.java:115)
    at weblogic.ejb20.deployer.ClientDrivenBeanInfoImpl.activate(ClientDrivenBeanInfoImpl.java:927)
    at weblogic.ejb20.deployer.EJBDeployer.activate(EJBDeployer.java:1302)
    at weblogic.ejb20.deployer.EJBModule.activate(EJBModule.java:342)
    at weblogic.j2ee.J2EEApplicationContainer.activateModule(J2EEApplicationContainer.java:1509)
    at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:970)
    at weblogic.j2ee.J2EEApplicationContainer.activate(J2EEApplicationContainer.java:957)
    at weblogic.management.deploy.slave.SlaveDeployer.processPrepareTask(SlaveDeployer.java:1074)
    at weblogic.management.deploy.slave.SlaveDeployer.prepareUpdate(SlaveDeployer.java:700)
    at weblogic.drs.internal.SlaveCallbackHandler$1.execute(SlaveCallbackHandler.java:24)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:152)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:133)

    Threaded Messages (4)

  2. Same problem!!![ Go to top ]

    Hi,

    I am also using WLS7 and I also tried to use JDK1.4.1 with it but faced similiar problem.In fact,when i tried to use 1.4.1, restarting WLS server through the web based console became impossible,because it simply used to reboot my PC.

    I guess it is a WLS7.0 issue.
  3. yes it is[ Go to top ]

    Weblogic 7 is not complient with jdk1.4. They have documented it on edocs.bea.com as well. Only version of weblogic which can run on jdk1.4 is 8.1
  4. yes it is[ Go to top ]

    oh, thanks very much!
  5. The same problem[ Go to top ]

    All right ! When I used Bea Weblogic 7.0 with jdk 1.4.1, I have the same problem. Although I have config a file start Weblogic server, "startWebLogic.bat". In my opinion, errors maybe cause permission of Bea WebLigic.